Changes between Version 1 and Version 2 of doc/upgrade/AuthenticationServerUpgrade

Show
Ignore:
Timestamp:
07/20/07 16:46:01 (13 years ago)
Author:
wmaalouf -@…
Comment:

i spent the day trying to fix up wifidog from broken version 2050.

Legend:

Unmodified
Added
Removed
Modified
  • doc/upgrade/AuthenticationServerUpgrade

    v1 v2  
    1111 1. Go to your auth server home page to make sure the schema has been updated (it may already have been by a random user accessing the auth server); 
    1212 1. If the Changelog mentioned dependency changes (or if unsure), start the install script till the dependencies page. 
     13 
     14= Tested stable revision packs =  
     15Although everytime wifidog should be reverse compatible when it is upgraded, sometimes it is inevitable that an update breaks something. When the user installs the newest wifidog version, he's taking a risk. The updated version might be broken because of work in progress, or new untested functionalities or modifications. (Happened to me) 
     16 
     17This section is for posting known and '''tested''' & working revision packs. Although newer packs may work while not being listed here, this is for people looking for a '''tested''' & working version because they don't want to go in the hassle of debugging their new version. The tester (or the person that upgraded to it successfully) should identify himself for backtracking purposes. 
     18 
     19To know your current revision number, use that command: ''svn info''. You need to be inside wifidog's folder. 
     20 
     21 '''Revision number:''' 1226 (Thu, 17 May 2007 at 16:25:43) - Tested by Wadz (wmaalouf -@at- fqccl d0t org) 
     22 [[br]] '''Details''': Well, I upgraded from version 1154 (Tue, 12 Dec 2006) to this version without problems. Just before, I tried to upgrade to the highest version (1250) but it crashed and I spent a couple of hours restoring and re-installing until I find a working version. The new database schema upgrade always failed, even when I installed from the scratch. So I finally got to version 1226, and it installed okay. (which is pretty new at the time we talk) 
     23 [[br]] --> '''To install from scratch''': ''svn -r 1226 checkout !https://dev.wifidog.org/svn/trunk/wifidog-auth'' 
     24 [[br]] --> '''To upgrade to''': ''svn update -r 1226''