Ticket #82 (closed Bug report: duplicate)

Opened 13 years ago

Last modified 12 years ago

Node Administration Page : Geolocalization failed

Reported by: Prospere Owned by: max-horvath
Priority: low Milestone: WifiDog Auth Server 1.0
Component: Auth server, Other Version: Auth Server SVN
Keywords: Cc:

Description

Geolocalization failed on the Administration page (admin/generic_object_admin.php).

Javascript Error : Error: window.opener.document.getElementById("node_NodeProspere_gis_latitude") has no properties Source File:  http://auth.puteaux-wireless.org/admin/hotspot_location_map.php?node_id=NodeProspere Line: 55


The fields on my administration page seems contain an id:

node_d80d6e87075fc709bd6015d89d6533fe_gis_latitude

And not "node_NodeProspere_gis_latitude"

Best regards,

Change History

Changed 13 years ago by Prospere

In hotspot_location_map.php :

$gis_lat_name = "node_".$this->getId()."_gis_latitude"; $gis_long_name = "node_".$this->getId()."_gis_longitude";

Should be replace by :

$gis_lat_name = "node_".md5($this->getId())."_gis_latitude"; $gis_long_name = "node_".md5($this->getId())."_gis_longitude";

Changed 13 years ago by Prospere

Not $this->getId() but $node->getId() :-)

Changed 13 years ago by max-horvath

  • owner set to max-horvath
  • status changed from new to assigned
  • milestone WifiDog Auth Server 1.0 deleted

Duplicate of #81

Changed 13 years ago by max-horvath

  • status changed from assigned to closed
  • resolution set to duplicate

Changed 13 years ago by max-horvath

  • milestone set to WifiDog Auth Server 1.0

Changed 12 years ago by benoitg

  • component changed from Auth server: Authentication to Auth server, Other
Note: See TracTickets for help on using tickets.