Ticket #537 (closed Bug report: worksforme)

Opened 10 years ago

Last modified 9 years ago

wifidog redirection issue

Reported by: mengjian@… Owned by: gbastien
Priority: low Milestone: Gateway 1.1.5
Component: Gateway Version:
Keywords: Cc:

Description

wifidog not redirect to portal page.

root@OpenWrt:/tmp/log# /etc/init.d/wifidog start Starting Wifidog ... Testing for iptables modules

Testing ipt_mac

ipt_mac module is working

Testing ipt_mark

ipt_mark module is working

Testing ipt_REDIRECT

ipt_REDIRECT module is working

OK root@OpenWrt:/tmp/log# iptables v1.4.0: Unknown arg `--to-ports' Try `iptables -h' or 'iptables --help' for more information.

Change History

Changed 10 years ago by mengjian@…

iptables v1.4.0 kamikaze 8.0.9 wifidog 1.1.5

any suggestion to this issue?

Changed 10 years ago by macjones

Confirmed again, you're not alone.....

Changed 10 years ago by Mac Jones

Recompiling specifically fo 2.6 kernel in kamikaze 8.09 fixed it for me, have sent you the binary.

Changed 10 years ago by ginji

The same for me someone now what to do ?

Changed 9 years ago by gbastien

  • owner set to gbastien
  • status changed from new to assigned

Trying to make it work on different versions of kamikaze myself... I will try to at least document this better.

Mac Jones, which image of kamikaze are you running and on what hardware?

Changed 9 years ago by gbastien

  • status changed from assigned to closed
  • resolution set to worksforme

There are additional dependencies for kamikaze 8.09 and up: kmod-ipt-nat-extra and iptables-mod-nat-extra

New instructions for compiling for kamikaze 8.09 can be found in the README.openwrt

Note: See TracTickets for help on using tickets.