Ticket #527 (closed Bug report: duplicate)

Opened 12 years ago

Last modified 11 years ago

Wifidog Gateway - Segfault in libc-2.7.so

Reported by: jean-philippe.menil@… Owned by:
Priority: high Milestone: Gateway 1.1.5
Component: Gateway Version: Gateway 20090925
Keywords: segfault, libc, wifidog Cc:

Change History

Changed 12 years ago by jean-philippe.menil@…

So, after a crash, analyse core done this:

#0 0x00007f89672913a1 in strncpy () from /lib/libc.so.6 #1 0x00007f89679a174e in httpdReadRequest (server=0x1ca4790, r=0x1cb37b0) at api.c:538 #2 0x000000000040b31a in thread_httpd (args=<value optimized out>) at httpd_thread.c:61 #3 0x00007f896756ffc7 in start_thread () from /lib/libpthread.so.0 #4 0x00007f89672e55ad in clone () from /lib/libc.so.6 #5 0x0000000000000000 in ?? ()

I try to understand.

Changed 12 years ago by jean-philippe.menil@…

Seems that this bug is the same like this one: http://dev.wifidog.org/ticket/471

??

Changed 12 years ago by jean-philippe.menil@…

All is ok now, after applying the workaround (http://dev.wifidog.org/ticket/471).

Changed 12 years ago by benoitg

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of #471

Changed 11 years ago by jodoreps

  • version set to Gateway 20090925
  • description modified (diff)
Note: See TracTickets for help on using tickets.