Ticket #474 (closed Feature Request: fixed)

Opened 10 years ago

Last modified 9 years ago

Allow email sub-adressing blocking to be turned off

Reported by: gabe@… Owned by:
Priority: high Milestone: WifiDog Auth Server 1.0
Component: Auth server, Feature request Version:
Keywords: Cc:

Description

From one of our (Wireless Toronto) users:

I just tried to create an account at  https://auth.wirelesstoronto.ca/, but your sign-up form handler incorrectly determined my email address to be invalid.

I suspect that you're using a too-restrictive formula for determining valid characters; I've seen this before, where sites block use od the plus character ("+").

Can you fix this please? I'd like to sign up, and possibly get involved in other ways.

For reference:  http://en.wikipedia.org/wiki/E-mail_address#Plus_.28or_Minus.29_addressing

Change History

Changed 9 years ago by benoitg

  • type changed from Bug report to Feature Request
  • component changed from Auth server, Authentication, permissions and access control to Auth server, Feature request
  • summary changed from error in email validation formula to Allow email sub-adressing blocking to be turned off

That's right, we block sub-adressing, on purpose. A patch is welcome if someone want's to make it configurable, but it's definitely not a bug.

Changed 9 years ago by networkfusion

  • milestone changed from Not yet assigned to a Milestone to WifiDog Auth Server 1.0

As sub addressing has now been added, this is now a priority...

Changed 9 years ago by gbastien

  • status changed from new to closed
  • resolution set to fixed

Fixed since [1424]

Note: See TracTickets for help on using tickets.