Ticket #427 (closed Bug report: worksforme)

Opened 14 years ago

Last modified 14 years ago

Query to database produces Fatal Error

Reported by: dondruce@… Owned by:
Priority: low Milestone: Not yet assigned to a Milestone
Component: Auth server, Statistics and reporting Version:
Keywords: Query Fatal Error Cc:

Description

When I try to Query a user in the database, I receive the following error message:

Fatal error: Uncaught exception 'ReflectionException?' with message 'Class Test does not exist' in /var/www/wifidog-auth/msf/classes/Content.php:389 Stack trace: #0 /var/www/wifidog-auth/msf/classes/Content.php(389): ReflectionClass?->construct('Test') #1 [internal function]: Content::isContentType(Array, 'Avatar') #2 /var/www/wifidog-auth/msf/classes/ContentTypeFilter.php(496): call_user_func_array(Array, Array) #3 /var/www/wifidog-auth/msf/classes/Content.php(512): ContentTypeFilter?->isAcceptableContentClass('Avatar') #4 /var/www/wifidog-auth/msf/classes/ProfileField.php(117): Content::getNewUI('063e0f1417b5acc...', Array) #5 /var/www/wifidog-auth/msf/classes/Profile.php(350): ProfileField::getNewUI('9513e081786a305...', Array) #6 /var/www/wifidog-auth/msf/classes/User.php(813): Profile->getAdminUI() #7 /var/www/wifidog-auth/msf/admin/generic_object_admin.php(413): User->getAdminUI() #8 {main} thrown in /var/www/wifidog-auth/msf/classes/Content.php on line 389

Attachments

Database Fatal Error.JPG Download (104.6 KB) - added by dondruce@… 14 years ago.

Change History

Changed 14 years ago by dondruce@…

Changed 14 years ago by benoitg

  • status changed from new to closed
  • resolution set to worksforme

Most likely, this is not a bug and you have 'Test' somewhere in your content type definitions. Check them all one by one.

Also, the line numbers do not match, you are not running latest SVN.

Note: See TracTickets for help on using tickets.