Ticket #423 (closed Bug report: duplicate)

Opened 10 years ago

Last modified 8 years ago

Redirection problems with Kamikaze

Reported by: miguelcma Owned by:
Priority: high Milestone: Gateway 1.1.5
Component: Gateway Version: Gateway 20090925
Keywords: Cc: benoitg

Change History

  Changed 10 years ago by zukky at ninjin-net.net

Hi, all.

I've confirmed the issue. When It happens, /etc/init.d/wifidog restart or /etc/init.d/firewall restart aren't effective. Reboot is the last way.

My environment is Buffalo WHR-G54S kamikaze 7.09 wifidog 1.1.4 .

Thanks,

zukky

  Changed 10 years ago by acv

Benoit has released a kamikaze compatible gateway, is this problem still present?

  Changed 10 years ago by miguelcma

acv, yes, the problem is still present.

  Changed 10 years ago by wichert

pastebin appears to be down. Can you upload those logfiles as attachments to this ticket?

  Changed 9 years ago by tj@…

I believe this may actually be a kamikaze issue  https://dev.openwrt.org/ticket/2558 and not specific to wifidog.

I suspect the REDIRECT rule in wifidog is being affected by the same kamikaze bug. As far as I can tell it doesn't look like it was a bug in netfilter itself. I haven't been able to specifically attribute it to wifidog. However, I have not been able to confirm that the similar behavior I have seen is the same thing in the openwrt report either.

follow-up: ↓ 8   Changed 9 years ago by Mac Jones

Seems to be fixed on 2.6 kernel Kamakaze.

Do not use 2.4 kernel for Kamakaze if you don't want this bug.

follow-up: ↓ 9   Changed 9 years ago by Mac Jones

to quote a post ....

Problem can by fixed by this way:  http://forum.openwrt.org/viewtopic.php?id=13533

Last page has a .trx file build to try.

in reply to: ↑ 6   Changed 9 years ago by Mac Jones

Replying to Mac Jones:

Seems to be fixed on 2.6 kernel Kamakaze. Do not use 2.4 kernel for Kamakaze if you don't want this bug.

Do not use 2.6 if you want stable wireless. :-)

Rock <-> Hard Place

in reply to: ↑ 7   Changed 9 years ago by tj@…

Replying to Mac Jones:

to quote a post .... Problem can by fixed by this way:  http://forum.openwrt.org/viewtopic.php?id=13533 Last page has a .trx file build to try.

Latest news in that thread is that a fix has been incorporated into 8.09 and kamikaze Ticket #2558 has been closed.

  Changed 9 years ago by benoitg

  • status changed from new to closed
  • resolution set to duplicate

Ok, so this wasn't wifidog bug after all. And openwrt has fixed it in both 2.4 and 2.6 kernels:  https://dev.openwrt.org/ticket/2558

  Changed 8 years ago by jodoreps

  • version set to Gateway 20090925
  • description modified (diff)
Note: See TracTickets for help on using tickets.