Ticket #292 (closed Bug report: fixed)

Opened 14 years ago

Last modified 14 years ago

Timeout regression in gateway SVN

Reported by: benoitg Owned by:
Priority: blocker Milestone: Gateway 1.1.3
Component: Gateway Version:
Keywords: Cc:

Description

There has been a regression in recent versions of the gateway (it isn't clear when it started). Normally the gateway sends a regular ping to each client with an open session, to keep the session open if they are still connected. However, it seems that now the ping isn't sent, or not properly detected, even for laptops without a misconfigured firewall.

Furthermore, the DHCP trick documented here doesn't seem to work properly. Note that may have a different cause.

Right now, the only workaround is increasing ClientTimeout to make the issue less apparent.

So far we know that the problem isn't with the traffic detection itself. So most likely the ping isn't sent at all, or the firewall ordering cause the replies not to be marked.

Change History

Changed 14 years ago by benoitg

  • priority changed from high to blocker

Changed 14 years ago by benoitg

  • status changed from new to closed
  • resolution set to fixed

Fixed in [1223]

Note: See TracTickets for help on using tickets.