Ticket #282 (closed Bug report: fixed)

Opened 11 years ago

Last modified 11 years ago

Problem with Node::getCurrentNode()

Reported by: benoitg Owned by:
Priority: normal Milestone: WifiDog Auth Server 1.0
Component: Auth server, Other Version:
Keywords: Cc:

Description

The recent Smarty centralization exposed a rather complicated bug with the current node detection. The most obvious manifestation of the problem is that most the number of online users displayed on the portal is frequently incorrect.

There are currently two different concepts of the current node (one in the session and one in the Node class property). These must be harmonized/simplified for the Node object to use the session one unless overriden.

Change History

Changed 11 years ago by benoitg

  • status changed from new to closed
  • resolution set to fixed

Fixed in [1173]

Note: See TracTickets for help on using tickets.