Ticket #28 (closed Bug report: Fixed)

Opened 15 years ago

Last modified 13 years ago

Radius logout is broken due to User::logout

Reported by: kakaouete Owned by: fproulx
Priority: normal Milestone: WifiDog Auth Server 1.0
Component: Auth server, Authentication, permissions and access control Version: Auth Server SVN
Keywords: Cc:

Description (last modified by max-horvath) (diff)

Hi, i already talked about that on the ml, i post it
here too to make this bug easier to track.

When a user authenticated with radius log out, i get
this error :
Notice: Undefined index: now in
/var/www/wifidog/classes/AuthenticatorRadius.php on
line 297

Warning: strtotime() [function.strtotime]: Called with
an empty
time parameter. in
/var/www/wifidog/classes/AuthenticatorRadius.php on
line 297

Notice: Undefined index: timestamp_in in
/var/www/wifidog/classes/AuthenticatorRadius.php on
line 297

Warning: strtotime() [function.strtotime]: Called with
an empty
time parameter. in
/var/www/wifidog/classes/AuthenticatorRadius.php on
line 297

Notice: Undefined index: username in
/var/www/wifidog/classes/AuthenticatorRadius.php on
line 302


The problem is AuthenticatorRadius::logout() who is
using $info, an array that should contain some row like
now, username and others.

But the function who calls
AuthenticatorRadius::logout(), User::logout() doesnt
send the right information.

I think it should just call logout with $connection
instead of this strange array.

i made a patch who is not really good, but i think that
benoitg is on it :]

Change History

Changed 15 years ago by fproulx

Logged In: YES 
user_id=1245118

I fixed it on my dev box, could not effectively try with raduis, but it's the 
same as long as the data is there. Will post when stable.

Changed 15 years ago by fproulx

  • status changed from assigned to closed

Changed 14 years ago by max-horvath

  • version changed from None to Auth Server SVN
  • component changed from Auth server: Authentication to Auth server: Authentication
  • description modified (diff)
  • milestone set to WifiDog Auth Server 1.0

Changed 14 years ago by benoitg

  • component changed from Auth server: Authentication to Auth server, Authentication
Note: See TracTickets for help on using tickets.