Ticket #270 (closed Bug report: fixed)

Opened 11 years ago

Last modified 11 years ago

Auth Server Installation - php 5.2.0 problem

Reported by: andrew@… Owned by:
Priority: high Milestone: WifiDog Auth Server 1.0
Component: Auth server, Install script Version:
Keywords: Cc:

Description

I was trying to install the auth server and when I got to the Administrator addition section I kept getting an error:

Fatal error: Cannot redeclare class DateTime? in /opt/wifidog-auth/wifidog/classes/DateTime.php on line 55

I found this page

 http://beeblex.com/search.php?s=l%3Aphp.pear.general&d=ALLDB&o=1&st=0&c=20&rss=0&r=0

Which made me think it was a problem with php 5.2.0 so I rolled back to version 5.1.6 and the install finished fine.

Change History

Changed 11 years ago by benoitg

  • priority changed from low to high
  • milestone set to WifiDog Auth Server 1.0

Stupid PHP language designers! They removed the "Date" class after script writers rightfully screamed bloody murder. They now decided to reintroduce it, this time as "DateTime?". After all, no one writing PHP could ever have thought of naming a Date and Time handling class DateTime?, right?

Changed 11 years ago by benoitg

Oh, I forgot: obviously, the solution for us is to rename the class DateTimeNoOneWillThinkOfThisName?, or something similar...

Changed 11 years ago by benoitg

An untested fix is in [1145]

Changed 11 years ago by adam@…

Works for me, however now moved onto the next error with php 5.2.0-

PHP Fatal error: Cannot access protected property TrivialLangstring::$content_row in /usr/home/forda/wifi/authserv/htdocs/classes/Content.php on line 115

Changed 11 years ago by benoitg

  • status changed from new to closed
  • resolution set to fixed

I fixed all PHP 5.2 compatibility issues I could find in [1155]. However, I couldn't reproduce the last one, and this needs further testing by someone running 5.2 in production.

Note: See TracTickets for help on using tickets.