Ticket #269 (closed Bug report: fixed)

Opened 15 years ago

Last modified 15 years ago

Users are not logged out automatically after the gateway crashed or was powered off

Reported by: lbc@… Owned by:
Priority: high Milestone:
Component: Gateway and Auth server Version:
Keywords: Cc:

Description

Users are not logged out automatically after the gateway crashed or has been powered off. The token remains INUSE and furthermore prevents logging in under the same user id a second time. Accepting a new token in the gateway helps to work around this bug, but users are still not logged out from the auth server. Reason is a non-working garbagge_collect() function (doesn't work in the MainUI class nor in the cron script 'cleanup.php').

Change History

Changed 15 years ago by benoitg

Is there an error message displayed?

Changed 15 years ago by benoitg

I've been trying unsuccessfully to hunt a bug down on IRC with greg, and it's very likely that the cause is the same as #269. The date comparison calculations for tokens appear to be failing. In this case, the offset makes wifidog to think that the token is still valid before it expired, and manifests as users not logging off automatically after a gateway crash or session expiration. In greg's case (offset probably the other way around), it manifests as users successfully logging in during initial auth (as shown by the gateway debug output) but getting logged off during the next counter update. I checked that the calculation hasn't been broken in recent postgres, and that we are using the proper datatype. So most likely, in both cases, you have an improperly set timezone in either PHP or Postgres.

It should be possible to fix this easily in the wifidog code now that we no longer intend to support MySql?, but I'd like to first confirm that this is indeed the problem.

Changed 15 years ago by benoitg

  • status changed from new to closed
  • resolution set to fixed

Should be fixed in [1123]

Note: See TracTickets for help on using tickets.