Ticket #266 (closed Bug report: worksforme)

Opened 14 years ago

Last modified 14 years ago

Auth server chops get parameters from the get request of the initial URL

Reported by: benoitg Owned by: benoitg
Priority: normal Milestone: Gateway 1.1.3
Component: Gateway Version:
Keywords: http get parameters Cc:

Description

That means that the "Use the Internet" link won't work properly on GET queries.

Change History

  Changed 14 years ago by benoitg

  • component changed from Auth server, Other to Gateway
  • milestone changed from WifiDog Auth Server 1.0 to Gateway 1.1.3

Damn, seems this is a gateway bug after all!

  Changed 14 years ago by David

Hi, a fix for this is now included in:  http://dev.coova.org/wifidog.html

  Changed 14 years ago by benoitg

  • status changed from new to closed
  • resolution set to fixed

Should be fixed in [1236]

  Changed 14 years ago by florida

  • status changed from closed to reopened
  • resolution fixed deleted

hello

I compiled the last sources and I had this message.

then mv -f ".deps/http.Tpo" ".deps/http.Po"; else rm -f ".deps/http.Tpo" ; exit 1; fi

(22:06:44) florida: http.c: In function `http_callback_404': (22:06:44) florida: http.c:86: error: parse error before ')' token (22:06:44) florida: make[8]: *** [http.o] Erreur 1

I corrected the problem by removing to it) line 86

r->request.query;

thank you very much for your work

follow-up: ↓ 6   Changed 14 years ago by benoitg

Florida, was that before or after David commited 1239?

in reply to: ↑ 5   Changed 14 years ago by florida

hello

it's after David commited

line 86 ----> r->request.query);

the ) is not useful

I replaced this line by ----> r->request.query;

and now there is no more error message to compilation

  Changed 14 years ago by anonymous

The file concerned is http.c

  Changed 14 years ago by benoitg

  • status changed from reopened to closed
  • resolution set to worksforme

Something is wrong in your checkout, you may want to start with a clean one (or try svn revert). Line 86 isn't as you describe in SVN, and the ")" is needed to close the snprintf. See http://dev.wifidog.org/browser/trunk/wifidog/src/http.c

  Changed 14 years ago by florida

thank benoitg

sorry, the problem is solved

thank you for your assistance

Note: See TracTickets for help on using tickets.