Ticket #238 (closed Bug report: fixed)

Opened 14 years ago

Last modified 13 years ago

Config file location is hardcoded

Reported by: anonymous Owned by:
Priority: normal Milestone: Gateway 1.1.3
Component: Gateway Version:
Keywords: install Cc:

Description

I had manually created a OpenWRT direcotry and wifidog.conf file inside it I copied the contents from the trunk link. Before running the configure shell script. Configure shell script found the wididog.conf file and put all the other related files in the same directory. The wifidog -f -d 7 command looks for /etc/wididog.conf even though the new path is /usr/local/Openwrt/wifidog.conf.

Change History

Changed 14 years ago by benoitg

  • priority changed from low to normal
  • summary changed from configure shell script of wifidog to Config file location is hardcoded

The problem is in conf.h, the line: #define DEFAULT_CONFIGFILE "/etc/wifidog.conf"

Should use the prefix defined by the build system.

Changed 13 years ago by benoitg

  • status changed from new to closed
  • resolution set to fixed

Fixed in [1121]

Note: See TracTickets for help on using tickets.