Ticket #103 (closed Bug report: invalid)

Opened 13 years ago

Last modified 12 years ago

SPLASH_ONLY_USER can't be disabled

Reported by: prospere Owned by: benoitg
Priority: low Milestone: WifiDog Auth Server 1.0
Component: Auth server, Authentication, permissions and access control Version: Auth Server SVN
Keywords: Cc:

Description

Hi,

The SPLASH_ONLY_USER mode can't be disabled .. I'm trying to understand why the SPLASH_ONLY_USER is always recreated by Wifidog. All the nodes doesn't allow splash only users and the network also :

"FALSE" is put inside the database (in nodes->is_splash_only_node) "FALSE" is put inside the database (in network->allow_splash_only_nodes)

The comparaison inside the code is :

return (($this->mRowallow_splash_only_nodes? == 't' ) ? true : false);

't' seems for True ? Or it should be :

return (($this->mRowallow_splash_only_nodes? == 'true' ) ? true : false);

isn't it ?

Best Regards,

Change History

Changed 13 years ago by max-horvath

  • owner changed from max-horvath to benoitg

Changed 13 years ago by benoitg

  • status changed from new to closed
  • resolution set to invalid

It is always recreated so that various checks can see that the current user isn't the SPLASH_ONLY user. That's not a bug. As for 't', the compare is correct, SQL databases return 't' for the bolean value TRUE, that's just the way the standard is.

Changed 12 years ago by benoitg

  • component changed from Auth server: Authentication to Auth server, Authentication
Note: See TracTickets for help on using tickets.