Ticket #102 (closed Bug report: fixed)

Opened 13 years ago

Last modified 11 years ago

On LangString Content Item Editing Page, single and double quotes are unnecessarily escaped (with \)

Reported by: dana@… Owned by:
Priority: low Milestone: WifiDog Auth Server 1.0
Component: Auth server, Content Management Version: Auth Server SVN
Keywords: Cc:

Description

When editing a LangString?, if the content text area has text with single or double quotes, when saving the object, the text will have extra escape characters added unnecessarily. For example, if the following text is in the content box:

<p>You are about to access the Internet through a wireless access node ("Node") operated in cooperation with NYCwireless, a provider of free public wireless internet access (the "Service"). You may use the Service only if you agree to the following terms of service ("Agreement") each time you access the Service. If you agree with and accept the Agreement, then double-click the "ACCEPT" button below. If you do not agree with what you read below, then click the "I DO NOT ACCEPT" button and you will not be able to use the Service. This Agreement was last revised on August 21st, 2001.</p>

When saved, the text will appear as:

<p>You are about to access the Internet through a wireless access node (\"Node\") operated in cooperation with NYCwireless, a provider of free public wireless internet access (the \"Service\"). You may use the Service only if you agree to the following terms of service (\"Agreement\") each time you access the Service. If you agree with and accept the Agreement, then double-click the \"ACCEPT\" button below. If you do not agree with what you read below, then click the \"I DO NOT ACCEPT\" button and you will not be able to use the Service. This Agreement was last revised on August 21st, 2001.</p>

save again, and it appears as:

<p>You are about to access the Internet through a wireless access node (\\\"Node\\\") operated in cooperation with NYCwireless, a provider of free public wireless internet access (the \\\"Service\\\"). You may use the Service only if you agree to the following terms of service (\\\"Agreement\\\") each time you access the Service. If you agree with and accept the Agreement, then double-click the \\\"ACCEPT\\\" button below. If you do not agree with what you read below, then click the \\\"I DO NOT ACCEPT\\\" button and you will not be able to use the Service. This Agreement was last revised on August 21st, 2001.</p>

Change History

Changed 13 years ago by max-horvath

  • owner set to max-horvath
  • status changed from new to assigned
  • milestone set to WifiDog Auth Server 1.0

I'll review (and fix) that ...

Did you actually try to use the HTMLeditor content plugin instead?

PS: Please check your magic_quotes settings in php.ini ... has it been enabled?

Changed 13 years ago by benoitg

I can't reproduce this locally. It's most likely related to the recent changes in magic_quote handling. I tried to fix it by instpection in [992]. Somebody will need to test.

Changed 13 years ago by benoitg

  • priority changed from high to low

Changed priority to low, as it most likely doesn't occur unless you have magic_quote_gpc turned on, which is not recommended anyway.

Changed 13 years ago by max-horvath

  • owner max-horvath deleted
  • status changed from assigned to new

Changed 13 years ago by benoitg

  • status changed from new to closed
  • resolution set to fixed

As far as I know, this is fixed

Note: See TracTickets for help on using tickets.